Jump to content

Olá Tibiano! Notamos que você está com um adblocker ligado... 

Nós promovemos servidores dentro da comunidade, para que eles tenham visibilidade.

Por favor, nos ajude a continuar promovendo esses servidores. Adicione nosso domínio na whitelist de seu adblocker, ok? :)

  • 0
Kheus Andrade

[Resolvido] Erro do db.executeQuery()

Question

Versão do Servidor: TFS - 0.4
Tipo de Script: talkaction
Código:

Please login or register to see this spoiler.

eu criei essa função ai na pasta data/lib/050-functions.lua

mas quando tento usar tenho o seguinte erro:

 

[13:34:59.908] [Error - TalkAction Interface]
[13:34:59.910] data/talkactions/scripts/tournament.lua:onSay
[13:34:59.911] Description:
[13:34:59.912] data/lib/050-function.lua:752: attempt to call field 'executeQuery' (a nil value)
[13:34:59.914] stack traceback:
[13:34:59.915]  data/lib/050-function.lua:752: in function 'createTournament'
[13:34:59.916]  data/talkactions/scripts/tournament.lua:10: in function <data/talkactions/scripts/tournament.lua:3>

 

podem ajudar a resolver?

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
12 minutos atrás, Yan Liima disse:

A TFS 0.4 é diferente. Inves de db.executeQuery é apenas db.query. Só alterar isso.

funcionou, mas pode me tirar uma dúvida sobre uma coisa:

 

doBroadcastMessage("As incrições para o torneio foram abertas, level mínimo "..t[1].." level máximo "..t[2]..".")

 

no server aparece assim:

 

13:59 As incrições para o torneio foram abertas, level mínimo 150 level máximo 300.

 

os caracters não ficam certo, sabe como posso resolver?

Share this post


Link to post
Share on other sites
  • 0
4 minutos atrás, Kheus Andrade disse:

funcionou, mas pode me tirar uma dúvida sobre uma coisa:

 

doBroadcastMessage("As incrições para o torneio foram abertas, level mínimo "..t[1].." level máximo "..t[2]..".")

 

no server aparece assim:

 

13:59 As incrições para o torneio foram abertas, level mínimo 150 level máximo 300.

 

os caracters não ficam certo, sabe como posso resolver?

Você tem o notepad ++ instalado ai? Só ir em "formatar" e trocar o formato para ANSI ou se já estiver em ANSI, troque para UTF-8. Depois é só editar a frase de novo(caso necessario).

Sem títuloo.png

Share this post


Link to post
Share on other sites
  • 0
A questão neste tópico de suporte foi respondida e/ou o autor do tópico resolveu o problema. Este tópico está fechado e foi movido para

Please login or register to see this link.

. Se você tiver outras dúvidas, crie um novo tópico.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...